3406 B AIR TO AIR LOST POWER
Posted Fri, Mar 16 2012 08:49 PM CST
ROBERT HOFER
HOFER LAND & LIVESTOCK
WORDEN, MT

Posts: 5
Just rebuilt motor ran great for the first 3000 miles lost boost went from 32 to 18 replace air to air, air fuel diframe, lift pump, had new turbo put on at the time rebuild, checked air to air hoses any ideas thanks REPLY REPLY WITH QUOTE
Posted Sat, Mar 17 2012 09:47 AM CST
RICK GOBEL
GOBEL RANCH, LTD.
BATTLE MOUNTAIN, NV
530-218-9057

Posts: 17
Check the air to air. I've two new ones go bad on me. Any other symptoms, smoke, any noises, or anything else?

REPLY REPLY WITH QUOTE
Posted Sun, Mar 18 2012 07:50 PM CST
BEN PECK
PECK TRUCKING, INC
KEOTA, IA
319-936-5789

Posts: 4
Originally Posted by: ROBERT HOFER
Quote: "Just rebuilt motor ran great for the first 3000 miles lost boost went from 32 to 18 replace air to air, air fuel diframe, lift pump, had new turbo put on at the time rebuild, checked air to air hoses any ideas thanks"

It takes air, fuel, and heat to make power. Sounds like you've covered heat (good compression), and you've looked pretty close at your air. Check fuel filters first then look for fuel lines leaking air or just plain pinched or collapsing. That's all I got so good luck!
REPLY REPLY WITH QUOTE
Posted Mon, Mar 19 2012 10:30 AM CST
LYN WESTON
L P WESTON TRANSPORT LLC
RANDOLPH,, UT
435-881-6561

Posts: 5
REPLY REPLY WITH QUOTE
Posted Mon, Mar 19 2012 10:31 AM CST
LYN WESTON
L P WESTON TRANSPORT LLC
RANDOLPH,, UT
435-881-6561

Posts: 5
sounds like the fuel filter is plugged i had the same experience with a 3406 b i didnt think it could possably be the filter but changed it and wow . REPLY REPLY WITH QUOTE
Posted Wed, Mar 21 2012 09:24 PM CST
ROBERT HOFER
HOFER LAND & LIVESTOCK
WORDEN, MT

Posts: 5
Checked all the things that you guys said to every thing looked good. Truck didnt smoke at all when you got on it pulled all the injecters ( put new ones in when we rebuilt motor) out did a test on them all six where off the spray track put new cat injecters back in looks like we are back on track. Talked to cat about it and they said it happens more often then you think. In this case all six took a dump. REPLY REPLY WITH QUOTE
Posted Mon, Mar 26 2012 09:36 AM CST
BEN BROWNLOW
TEXAS CATTLE TRANSPORT LLC
LARUE, TX
903-391-0124

Posts: 6
went thru the same problem when i replaced injectors. i went with an oversize injector, drove about the same mileage as you, and the truck started running poorly. it had a miss in a pull and would loose power. pulled all the injectors and had them tested. had 4 bad! did not originally buy the oversize injectors thru CAT, but did replace them with CAT injectors and problem was solved. REPLY REPLY WITH QUOTE